Situation
You have logged in on boomla.com
and created a website either on boomla.net
subdomain like example.boomla.net
or on a custom domain like example.com
. When you visit your website, the toolbar does not show up.
Cause
When you visit your website, Boomla doesn't know it is you, you are effectively not logged in. This caused by blocked cookies.
To verify this:
Go to https://boomla.com/..login-status, it should say you are logged in. (If not, log in!)
Go to https://YOURDOMAIN/..login-status
and verify you are NOT logged in.
Why?
Boomla uses a central login system: you have to log in once on boomla.com, and as a result you will be logged in to all your websites. Log out, and you will be logged out everywhere. You can think of it as logging in to the Boomla Platform and not an individual website. This is required as most users end up having lots of websites/projects on Boomla sooner or later. Logging in to each of them individually would be a pain.
Technically, your browser is blocking cookies. It should allow using boomla.com
cookies from your website.
Solution 1
Open your website by clicking the open button on your Control Panel. This will take you through a special open path that makes sure are logged in. This works even if your browser's cookie settings are too strict and do not allow the automatic authentication method we use.
Solution 2
Try using another browser which may have different cookie settings. We only fully support Chrome and Firefox at the moment. Login issues are uncommon in Chrome, more common in Firefox, most common in Brave (a Chrome variant).
That's a great start to verify you can edit your website at least in one browser. See the other solutions to make your favorite browser work.
Please get in touch.